• twitter image
  • facebook image
  • youtube image
  • linkedin image
  • RSS
Language: CMS Made Simple Czech CMS Made Simple France CMS Made Simple Spain CMS Made Simple Hungary CMS Made Simple Russia CMS Made Simple, Belgium - the Netherlands
CMSMadeSimple.org
CMS Made Simple

Announcing CMS Made Simple 1.7 - Cape Verde

March 20, 2010

Blog | Downloads | Forum | Wiki

Announcing CMS Made Simple 1.7 - Cape Verde

This version marks a milestone for CMSMS, and although the changes in the code are minor, the ramifications are significant, so please read this article in it’s entirety.

As of this release we no longer support PHP 4.x – This means that you cannot upgrade your site to CMSMS 1.7 if your host is still running PHP 4.x. We encourage you to upgrade to PHP 5.2 or PHP 5.3 as soon as possible. This allows us to move forward with PHP and also as developers to take advantage of many of the new features in this programming language. If you could see me right now, you’d see me doing the dance of joy… PHP 4.x and PHP 5.x compatibility have been a thorn in our side for a long time.

Also, we now require PHP 5.2.4 as a minumum and recommend PHP 5.2.12 or PHP 5.3.1 and higher. Why these specific versions you ask? Well it’s a matter of experience. We have learned through much difficulty, and many days of debugging that some of the earlier versions of PHP 5.2.x were buggy, but have had reasonable success with version 5.2.4 and onwards. Additionally some users using some of the newer released modules that take serious advantage of some of the advanced features of PHP 5.x (like calguy1000's modules) will experience some (often strange) difficulties unless you are running a later version of PHP 5.2 or PHP 5.3.

In order to support PHP 5.3 in CMSMS and to release it as soon as possible, we did the minimal amount of changes required to get our functionality to be stable. This has some ramifications, particularly for those running the latest and greatest software in a development/testing environment. Specifically we require that E_STRICT and E_DEPRECATED be turned off from your error reporting.

E_STRICT:
As we stated above we did the minimal amount of changes required to get the functionality stable in PHP 5.3. Some of the core functionality still assumes PHP 4 and does some strange things that are against the model of PHP 5.3’s syntax. As well, some of the libraries that CMSMS uses for things like ajax do not support E_STRICT. We are also sure many of the add-on modules do too. Therefore E_STRICT must be disabled.

Note: E_STRICT is not included in E_ALL, however it may habve been turned on by your provider and may need to be overridden.

E_DEPRECATED:
Some modules (even some parts of the core) use functions that are valid in PHP 4, and in PHP 5.2.x, but are not valid in PHP 5.3. And to ensure that all of the functionality works as intended you will need to disable warnings about usage of these functions. Therefore E_DEPRECATED must also be disabled. This only applies to PHP 5.3.x

php.ini settings for PHP 5.2.x
The recommended value for error_reporting in your php.ini is:
error_reporting = E_ALL

.htacces settings for PHP 5.2.x
The error reporting value in a .htaccess file has to be specified as an integer.
php_value error_reporting 6143

error_reporting set directly in PHP
If none of these options work, you may have luck with this line in your config.php:
error_reporting(E_ALL);

php.ini settings for PHP 5.3.x
The recommended value for error_reporting in your php.ini is:
error_reporting = E_ALL & ~E_DEPRECATED

.htaccess settings for PHP 5.3.x
The error reporting value in a .htaccess file has to be specified as an integer.
php_value error_reporting 22527

error_reporting set directly in PHP
If none of these options work, you may have luck with this line in your config.php:
error_reporting(E_ALL & ~E_DEPRECATED);

Changes
Along with PHP 5.3 support, a handful of other changes and a sprinkling of minor bug fixes have been thrown into this release. The description of them follows:

Version 1.7 – Cape Verde
————————————-
- We now support php 5.3
Note: Minimum PHP Version required is 5.2.4 though we recommend PHP 5.2.12
– Users that are using many of the newer modules that take advantage of PHP 5’s OOP features
may experience strange problems when using earlier versions of PHP 5.2. It is therefore
recommended that your PHP version be updated frequently.
Note: We do NOT support E_DEPRECATED or E_STRICT at this time.
Note: We no longer support PHP 4.x
- The installer no longer performs smarty caching
- Improvements to TinYMCE
– Now not depending on admin-theme’s icons anymore. Thanks Nuno
– Updated to Tiny 3.3-final
– Added an option to generate cms-compatible thumbnails when uploading files though the filepicker.
- Search 1.6.2
– Adds the detailpage param (can be overriden by modules)
- ModuleManager 1.3.3
– Minor improvements… mostly for PHP 5.3
- Remove the long-deprecated ImageGallery plugin
- Various small bug fixes

Thanks
We would like to thank all of the dev team members (including JeremyBass our newest member) who spent hours making the appropriate changes and testing them.

We hope you enjoy this release, and feel free to use PHP 5.3 now….
Let the parties begin.

© Copyright 2004-2011 - CMS Made Simple | Powered by CMS Made Simple and NMS



A2 Hosting